How do I work with MicaSense GeoTiff's in QGIS and create a PDF report?

Now you can print and create basic PDF reports from Atlas: Printing from Atlas

Using ArcMap? Check out the ArcMap tutorial here.

Optional Step - Download QGIS

To download QGIS, simply go to ( and download the latest version that is appropriate for your Operating System. Follow the steps in the QGIS setup to install your version. Then, open QGIS.

1.    Download GeoTIFF from Atlas

Go to, then click the  for the image set(s) you are interested in.

2.    Drag and Drop Data into QGIS

Drag the downloaded GeoTIFF into QGIS. After it is loaded into QGIS, it should appear in your “Layers” menu.

3.    Set the Layer Properties

Set the layer properties by double-clicking on the layer, then setting the red band to “Band 3”, green band to “Band 2”, and blue band to “Band 1”. Set the cumulative count cut to 0.2-99.8% and click "Load". Then, look at the band rendering min/max values for all bands and find the greatest max value. Copy and paste that value as the max for all bands. Now find the smallest minimum value and copy and paste that as the min value for all bands. Lastly, to ensure that there is less aliasing when zooming in and out of the image, set the resampling to Nearest neighbor for zooming in, and Average for zooming out. Then, click “Apply”.

This will set the band rendering of the GeoTIFF so that the RGB colors are more similar to what you see in ATLAS.

4.    Calculate NDVI and NDRE with the Raster Calculator

NDVI and NDRE are the vegetation indices seen in ATLAS currently, but there are many more that can be calculated from a 5-band GeoTIFF. For more information on these indices, we recommend reading “Active Ground Optical Remote Sensing for Improved Monitoring of Seedling Stress in Nurseries” ( The formulas for calculating the spectral indices found in ATLAS are as follows:

To calculate spectral indices in QGIS, use the raster calculator (Raster>Raster Calculator). Double click the raster bands to add them into the expression box. Then, use the operator buttons to add parentheses, addition, subtraction, and division symbol (Note: Do not simply type in the necessary symbols, you must use the operator keys for this to work correctly). Be sure to check that the extent of the layer is correct. If needed, click the “current layer extent” button to adjust the extent to match the current layer. Lastly, choose the output file and layer name by clicking the “…” button next to the Output Layer box.

5.    Change Layer Color Scales to Match Atlas Output

You should see something similar to this in QGIS when your newly created layer finishes calculating.

To change the color scale of the layer, double click on the layer to open the layer properties. Click on the dropdown “Render Type” menu, and select Singleband pseudocolor. Change the color scale to what you believe to be most appropriate for your data, then click “Classify”.

To Recreate the NDVI Map Color Scale Seen in ATLAS…

Click the dropdown “Generate new color map” menu, and select RedYlGn. Change the Mode to Equal Inverval and Classes to 11. Set the Min to 0.5 and Max to 1, then click “Classify”. Double click on the red box next to the 0.5 value to change the color. Set the Opacity to 0%, then click OK.

In the Layer Properties, click Apply. The final layer properties window should look like similar to this:  

Create a PDF Report in QGIS

1.    Open Print Composer

Using the Menu Tool Bar seen at the top of your QGIS window navigate to Project>New Print Composer, or type CTRL+P. A window should pop up prompting you to give your print composer a name, you may name it or let QGIS auto-generate a name for you. This name is what your composer file (Not PDF) will be saved as so that you can go back and edit it later. After this, the composer screen should pop up.

2.    Change Page Size and Margins

Change your page side and margins to fit your preferences using the menu tool bar to navigate to Composer>Page Set Up (Or, simply type CTRL+Shift+P).

3.    Add Map to Composer

Add your map by navigating to Layout>Add Map. Drag a box on your composer window that is the appropriate size for your map.

Then, from your QGIS window (Not composer window), zoom in and out to change the extent of your map. Back on the Composer window, under Main properties, click “Set to map canvas extent”. Repeat this until the composer reflects your desired map extent.

4.    Add Scale Bar

Add a scale bar to your map by navigating to Layout>Add Scalebar. Click the location on the map where you want to place your scalebar. You can also drag and move your scalebar as you wish.

5.    Add Legend

Add a Legend to your map by navigating to Layout>Add Legend. Click the location on the map where you want to place your legend. You can also drag and move your legend as you wish.

6.    Add Text

Add a title, note, or any form of text to your map by navigating to Layout>Add Label. Click the location on the map where you want to place your text, then resize the box so that it has the appropriate margins. When you click on your map, the item properties menu should display automatically:

7.    Add a Logo or Other Relevant Images

Add an image to your map by navigating to Layout>Add Image. Click the location on the map where you want to place your legend, and drag such that the box is the desired size. The item properties should appear to the left of your map. Select the image you wish to use by changing the Image Source by clicking “…”.  Change the resize mode and placement as you see fit. After you are satisfied with your image, you can move and resize the image within the composer window.

8.    Save as PDF

Save your composer as a PDF by navigating to Composer>Export as PDF. Select the file name and location you wish to save your PDF in, then click “Save”.

Have more questions? Submit a request